Magnum Remote Compatibility

Magnum Energy’s Remote Control’s (ME-RC, ME-ARC and ME-RTR) have many advanced settings, and are designed to work with the advanced features in your Magnum inverter and/or other Magnum devices (i.e., ME-AGS-N or ME-BMK).

These remotes communicate with your inverter to allow the advanced features to be set up or enabled. However, your inverter may not have the advanced feature requested by the remote.

If this is the case, the advanced setting request from the remote to your inverter (or any other Magnum device networked with the inverter) is not recognized and will not function. A feature/setting compatibility sheet is provided below for your inverter to allow you to determine which remote menus/features are compatible with your inverter.

Step One:

Determine your inverter’s compatibility level using the following table.

  • Find your inverter model in the first column.

  • Determine your compatibility level based on your software revision.

    • Obtain your inverter’s software revision level by pushing the TECH button on your remote and access the REVISIONS menu.

 

Inverter/Charger Model Level 1 (L1) Level 2 (L2) Level 3 (L3) Level 4 (L4)
RD1824 ≥ Rev 2.6 ≥ Rev 3.4 NA ≥ Rev 5.4
RD2212 - ≥ Rev 3.4 NA ≥ Rev 5.4
RD2624E - - ≥ Rev 4.1 ≥ Rev 5.4
RD2824 ≥ Rev 2.6 ≥ Rev 3.4 NA ≥ Rev 5.4
RD3924 ≥ Rev 2.6 ≥ Rev 3.4 NA ≥ Rev 5.4
RD4024E - - ≥ Rev 4.1 ≥ Rev 5.4
ME2000 ≥ Rev 2.6  ≥ Rev 3.6 ≥ Rev 4.2 ≥ Rev 5.4
ME2012 ≥ Rev 2.6 ≥ Rev 3.6 ≥ Rev 4.2 ≥ Rev 5.4
ME2512 ≥ Rev 2.6 ≥ Rev 3.6 NA ≥ Rev 5.4
ME3112 ≥ Rev 2.6 ≥ Rev 3.6 NA ≥ Rev 5.4
MM612 - ≥ Rev 1.0 NA NA
MM612AE - ≥ Rev 1.0 NA NA
MM1012E - ≥ Rev 1.1 ≥ Rev 1.4 NA
MM1212 - ≥ Rev 1.0 ≥ Rev 1.4 NA
MM1212AE - ≥ Rev 1.0 ≥ Rev 1.4 NA
MM1324AE - ≥ Rev 1.2 ≥ Rev 1.4 NA
MM1512AE - ≥ Rev 1.3 ≥ Rev 1.4 NA
MM1524AE - ≥ Rev 1.1 ≥ Rev 1.4 NA
MMS912E - - ≥ Rev 1.5 NA
MMS1012(G) - ≥ Rev 1.0 ≥ Rev 1.4 NA
MS1512E - - - ≥ Rev 5.2
MS2000 - ≥ Rev 3.2 ≥ Rev 3.7 ≥ Rev 5.4
MS2012 - ≥ Rev 3.2 ≥ Rev 3.7 ≥ Rev 5.4
MS2024 - - ≥ Rev 3.8 ≥ Rev 5.0
MS2812 - ≥ Rev 3.2 ≥ Rev 3.7 ≥ Rev 5.4
MS2712E - - ≥ Rev 3.8 NA
MS3748AEJ - - ≥ Rev 3.8 NA
MS4024 - ≥ Rev 3.3 ≥ Rev 3.7 ≥ Rev 5.4
MS4024AE - ≥ Rev 3.3 ≥ Rev 3.7 NA
MS4024PAE - - - ≥ Rev 4.0
MS4048 - - - ≥ Rev 5.7
MS4124E - - ≥ Rev 3.8 ≥ Rev 5.3
MS4124PE - - - ≥ Rev 5.5
MS4348PE - - - ≥ Rev 5.5
MS4448AE - ≥ Rev 3.3 ≥ Rev 3.7 NA
MS4448PAE - - - ≥ Rev 4.1
MSH3012M - - - ≥ Rev 1.1
MSH4024M - - - ≥ Rev 1.1
MSH4024RE - - - ≥ Rev 1.1

Step Two:

Once you have determined your Inverter’s Compatibility Level, choose the appropriate document below based on your remote control and its software revision. Page two shows the the inverter compatibility level required to use particular menu feature/settings in your remote.

If your inverter’s compatibility level is the same or greater than the inverter compatibility level REQUIRED shown in the Compatibility Matrix, then your inverter can support the device feature/setting you want to use.

ME-ARC (Revs 2.3 and 2.4) Inverter Compatibility Matrix (64-0030-03 Rev 1-12)
ME-ARC (Revs 3.0 and 3.01) Inverter Compatibility Matrix (64-0030-30, Rev C)
ME-ARC (Rev 4.0) Inverter Compatibility Matrix (64-0030-040, Rev C)
ME-RC (Rev 2.7) Inverter Compatibility Matrix (64-0003-027, Rev E)
ME-RC (Rev 2.8) Inverter Compatibility Matrix (64-0003-028, Rev C)
ME-RTR (Rev 3.1) Inverter Compatibility Matrix (64-0020-031, Rev C)